By using technology, students can conduct an experiment that quickly simulates a large number of random events. Much research has been done on students’ conceptions and reasoning about probability (Jones et al. 2007). Recommendations for teaching probability have included just such use of concrete and digital manipulatives to simulate events as well as students’ reflection on their initial predictions and analysis of their experiments and their results (NCTM 2000; Van de Walle et al. 2010). In fact, by using Excel® and Visual Basic to simulate coin flipping, students have been able to capitalize on these technological benefits to investigate, conceptualize, and refine their understanding of the law of large numbers.

**THE PROBLEM**

Which has the higher probability—
(a) getting exactly 5 heads and 5 tails in 10 flips of a fair coin; or
(b) getting exactly 50 heads and 50 tails in 100 flips of a fair coin?

Informally, the law of large numbers states that the relative frequency of outcomes becomes a closer approximation of the theoretical probability of an event as the size of the data set increases (Van de Walle et al. 2010). Students often misinterpret this law in the context of coin flipping. They believe that, as the number of flips increases, the number of tails and the number of heads approach each other. Therefore, when presented with the problem above, they believe that the correct answer is (b).

**AN OVERVIEW**

After students make and justify their predictions, they can investigate the problem by using a programmed Excel 2007 workbook containing three worksheets. The first two worksheets (see fig. 1) simulate flipping a coin 10 times and 100 times, respectively, and record and display the outcomes in a column graph for each of 1000 trials. Worksheet 3 (see fig. 2) captures the recorded data from worksheets 1 and 2 in a frequency chart and generates a column graph, so that students can easily compare outcomes from both flip sequences. By analyzing the generated representations, students are able to reason why getting exactly 5 heads and 5 tails in 10 flips of a fair coin is more likely than getting exactly 50 heads and 50 tails in 100 flips of a fair coin.

**WORKSHEETS 1 AND 2**

Before entering values and formulas, format worksheets 1 and 2 by inserting the appropriate text into cells A3, C4, C5, C6, and D4 (see fig. 3). Note that the heading "Number of Heads" is in a text box. To create a text box, click on the Insert tab, click on the Text Box button, and drag and drop the text box so that it is centered over cell A1; then enter the text. To change the color of the text box, select the text box, go to the Home tab, and select the drop-down arrow on the Fill Color icon to choose a color.
To format the frequency table, highlight cells C4–D6, click on the Home tab, select the drop-down arrow on the Border icon, and click on All Borders. You may choose to alter the background color of the cells by selecting the cells, clicking on the Home tab, and clicking on the drop-down arrow on the Fill Color icon to choose a color.

Worksheets 1 and 2 are similar, except that worksheet 1 has 10 values in the Results column (representing a sequence of 10 flips) and worksheet 2 has 100 values in the Results column (representing a sequence of 100 flips). A description of how to create worksheet 1 follows; any code that differs for worksheet 2 is placed in braces. Following discussion of the initial setup of worksheets 1 and 2, details are provided for how to flip a sequence of coins, how to create a dynamically linked frequency chart and column graph of the outcomes, and how to code two macro buttons that record trial results.

To simulate flipping a fair coin, use the RandBetween function. RandBetween generates a random integer between the values specified in a given selection of cells. In cells A4–A13 {A4–A103}, enter =RandBetween(0,1). Use the Fill Down command (Ctrl-D) to populate these cells. Let 0 represent obtaining a head and let 1 represent obtaining a tail on a given flip.

To create a frequency chart of obtained results, use the CountIf function, which counts a designated entry within a selection of cells. In D5, type =CountIf(A4:A13,”0”) {=CountIf(A4:A103, “0”)} to count the number of heads obtained on the sequence of coin flips. In D6, type =CountIf(A4:A13,”1”) {=CountIf(A4:A103, “1”)} to count the number of tails obtained in the sequence of coin flips.

To create a dynamic visual of the total number of heads and tails obtained when flipping a coin 10 times, follow these steps: Highlight cells C5–D6, click on the Insert tab, click on the Column Chart button, and select 2-D Clustered Column. To obtain the appropriate column chart, right-click on the inserted chart and choose Select Data. Under the Horizontal (Category) Axis labels, choose Edit. Highlight cells C5 and C6, and then click on OK. You may add chart titles, axis titles, and data labels to the column chart by clicking on the chart and using the features located in the Label menu under the Layout tab.

Fig. 1 Spreadsheets can be constructed to illustrate the coin-flipping experiment. The screenshots show the 1000th result of flipping a coin 10 times (a) and 100 times (b).

Fig. 2 Excel allows students to see multiple, dynamically linked representations of the data.

When you press the recalculation key, typically F9 or CMD =, Excel will simulate flipping a coin 10 times as well as capture and graph the number of heads and tails that occur in the sequence of these 10 flips. However, each time the recalculation key is pressed, the previous data set is erased and replaced by a new set.

Repeat these steps for worksheet 2.

For future coding, name the worksheets and workbook accordingly.
A macro is a sequence of commands that is stored in a Visual Basic code file (a module). You will create macros and buttons linked to them so that, on clicking, the respective macros will be activated. These buttons are created by writing code directly into the module. The two buttons you create are Record Trial and 1000 Trials. The Record Trial button records the total number of heads that occurred in one trial. The 1000 Trials button records the total number of heads that occurred in each of 1000 trials.

To create a button that runs a macro, place the Developer tab in the Ribbon. Click on the Microsoft Office button and select excel options. (Some users may have to select Prepare before choosing excel options.) Choose Popular Menu and check Show Developers tab in the Ribbon (see fig. 5). Now select Formulas from the Options Menu at the left. Select Manual under Calculation Options, uncheck the box that says Recalculate workbook before saving (see fig. 6), and then click on OK.

To capture outcomes of multiple trials, you will create macro buttons using Visual Basic, a programming language built into Excel. The workbook CoinFlipping, choose Excel Macro-Enabled Workbook (see fig. 4) in the drop-down box beside Save as type and click on Save. Name each worksheet according to its placement in the workbook. For example, the first worksheet will be called Worksheet 1.

Anytime an Excel macro-enabled workbook is opened, Excel will present a pop-up security warning stating that Macros have been disabled if the macro security setting is set to Disable all macros with notification. This setting can be found on the Developer tab in Macro Security under the Macro Setting menu. To enable the macros, select the Options button immediately to the right of the security warning, select Enable this content, and click on OK.

MACRO BUTTONS
To capture outcomes of multiple trials, you will create macro buttons using Visual Basic, a programming language built into Excel. A macro is a sequence of commands that is stored in a Visual Basic code file (a module). You will create macros and buttons linked to them so that, on clicking, the respective macros will be activated. These buttons are created by writing code directly into the module. The two buttons you create are Record Trial and 1000 Trials. The Record Trial button records the total number of heads that occurred in one trial. The 1000 Trials button records the total number of heads that occurred in each of 1000 trials.

To create a button that runs a macro, place the Developer tab in the Ribbon. Click on the Microsoft Office button and select excel options. (Some users may have to select Prepare before choosing excel options.) Choose Popular Menu and check Show Developers tab in the Ribbon (see fig. 5). Now select Formulas from the Options Menu at the left. Select Manual under Calculation Options, uncheck the box that says Recalculate workbook before saving (see fig. 6), and then click on OK.

RECORD TRIAL BUTTON
To insert a button, click Insert under the Developer tab and select the Button icon in Form Controls (see fig. 7). On clicking on the Button icon, drop the button into your worksheet. The Assign Macro window will pop up. Clicking on New will open a module in Visual Basic. In this window, type the code in figure 8. This code accesses the total number of heads value that is located in cell D5 and places it into the first available cell (moving downward in Column L). To ensure that a value in Column L is never replaced, cell M1 is used as a counter that is updated each time the button is pressed. This counter also keeps track of the number of times you have recorded a value in
Column L. Save your code (Ctrl S) and return to the spreadsheet.

To program the counter, type =1+CountA(L1:L1000) in cell M1. By using the range L1–L1000, M1 will count a maximum of 1000 simulations.

**1000 TRIALS BUTTON**

The purpose of the 1000 Trials button is to eliminate the need to click on the Record Trial button 1000 times to obtain results for 1000 trials. To create the 1000 Trials button, insert a Form Controls button from the Developer tab and drop it into your worksheet. After clicking on New, you will see the code of your first button. Below Sub Button2_Click(), enter the code shown in Figure 9. This code first removes all previous recorded values in column L. Surrounding the Application.Run statement, which activates the Record Trial code, with a For-To loop simulates flipping a coin 10 times and records the number of heads obtained in each of the 1000 trials. Save your code (Ctrl S), return to Excel, and name this button 1000 Trials.

You have now completed worksheet 1 and can repeat the directions to create worksheet 2. Note that each time you introduce a button, it will be given a name Button#_Click() in which the number(#) will increase. When you code the 1000 Trials button in worksheet 2, make sure that your Application.Run statement refers to the Record Trials button in worksheet 2. Figure 10 shows all four codes in Visual Basic Editor.

**WORKSHEET 3**

Worksheet 3 links the information from the two previous worksheets to create frequency charts and column graphs of the total number of heads obtained from 1000 trials of flipping a coin 10 times and 100 times (both shown in fig. 1). Before linking values, format...
Return to worksheet 1, highlight cells L1–L1000, and copy them. In worksheet 3, select cell B5, right-click, select Paste Special, and click on the Paste Link button.

Now, students will create frequency charts and column graphs, as shown in figure 2. To create a frequency chart for worksheet 1 data, highlight E5–E15 in worksheet 3; type =Frequency(B5:B1004, D5:D15) in the formula bar; and press and hold the following keys in order: Ctrl, Shift, Enter. To create a frequency chart for worksheet 2 data, highlight K5–K105 in worksheet 3; type =Frequency(H5:H1004, J5:J105) in the formula bar; and then press and hold the following keys in order: Ctrl, Shift, Enter. With these frequency charts, you can now insert a column graph for each data set.

To create a column graph for the 1000 trials of flipping a coin 10 times, highlight cells E5–E15, click on the Insert tab, click on the column chart button, and select 2-D Clustered Column. Now, in the graph, right-click on a column in the column graph. Click on Select Data. In the new screen, under Horizontal (Category) Axis Labels, click on Edit. Highlight D5–D15. Click OK twice.

To create a column graph for the 1000 trials of flipping a coin 100 times, highlight cells K5–K105, click on the Insert tab, click on the column chart button, and select 2-D Clustered Column. Now, in the graph, right-click on a column in the column graph. Click on Select Data. In the new screen, under Horizontal (Category) Axis Labels, click on Edit. Highlight J5–J105. Click OK twice. You may add a title, labels, and fixed vertical axis values by using the features in the Layout tab (see fig. 2).

PUTTING THE WORKSHEETS INTO PRACTICE
Before using this workbook in the classroom, delete the entries under the Results column and in cells L1–L1000 in both worksheets 1 and 2. This procedure allows students to enter the RandBetween function under the Results column, collect data, and view the dynamic representations.

As students run the simulation, have them answer the following questions:

1. Out of 1000 trials, what was the largest discrepancy between the
number of heads and the number of tails obtained within one trial for a sequence of 10 flips? For a sequence of 100 flips?

2. Out of 1000 trials, were there any results of heads obtained that appeared to occur more often than others within the sequence of 10 flips? Within the sequence of 100 flips?

3. For the 10 flips sequence, what is the total number of heads that occurred over 1000 trials? What is the average number of heads that occurred?

4. For the 100 flips sequence, what is the total number of heads that occurred over 1000 trials? What is the average number of heads that occurred?

5. Which of the following has a higher probability—getting exactly 5 heads and 5 tails in 10 flips of a fair coin or getting exactly 50 heads and 50 tails in 100 flips of a fair coin?

6. Which of the following has a higher probability—getting 40 to 60 percent heads in 10 flips of a fair coin or getting 40 to 60 percent heads in 100 flips of a fair coin?

At the end of the activity, have students discuss their initial predictions, the process and results of the simulations, their answers to and reasoning about the questions above, and their understanding of the law of large numbers.

BIBLIOGRAPHY


NICOLE R. JUERSIVICH, njuersi9@naz.edu, teaches mathematics and mathematics education at Nazareth College in Rochester, New York. Her interests include the use of technology to enhance student comprehension for learning and teaching of mathematics.

Editor’s note: See also Laurie H. Rubel, “Connecting Research to Teaching: Is 7/10 Always Equivalent to 700/1000?” MT September 2010 (vol. 104, no. 2, pp. 144–47).